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1 Overview
This part tells how to make your own page sets, starting with empty pages.

You'll be surprised how quickly and easily you can create beautiful, function-filled pages.

• Quick Tour of Edit View shows where to find the most frequently used tools.
• Basic Page Set Creation covers what you need to create simple Communication pages and link them together.
• Controlling How it Looks introduces the tools and commands that let you customize button and page appearance.
• In Adding Actions and Smart Behavior, learn how to use the functionality from the Feature Tabs such as E-mail, Games,

Music Player and the like in your own page sets.
• Re-using Your Work tells how you can copy from the Ready-Made page sets into your own page sets, or re-use your

own work in different page sets.

Making Your Own Page Sets Reference manual v.1.0 - en-US 1 Overview 7



2 Quick Tour of Edit View
Edit view provides the tools you need to create or modify your own page sets.

2.1 What's in the Work Area?

Figure 2.1 Edit View

Numbered areas in above picture:

1. Run page set

2. Go to Edit view

3. Pointer tool

4. Edit Toolbox

5. Page list

6. Selected page

7. Selected button

8. Picture Search

2.2 Turning Toolbars Off and On
1. To turn the different toolbars or window features off or on, use the menu command View > Toolbars.

2. Choose the toolbar name to turn it off or on.

3. Features with golden check boxes are turned on in your Communicator window.

2.3 Point at the Icon for a Tool Tip
Rest the mouse pointer over any icon to see what that tool will do if you select it.

2.4 Important Tools
This is the Standard toolbar. If you recognize a tool fromWindows, for example New, Save, Print, Redo or Undo - then the tool
will do the same in Communicator as in any other Windows program.
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Notice the tool to Run your page set. Selecting the Run icon is the same as giving the menu command View > Run view, or
pressing F5. Beside it is the Edit view tool - we are in Edit view here, so the button is selected.

Figure 2.2 Standard Toolbar

This is the Edit Toolbox. It is always present in Edit view, and always in the same place.

Figure 2.3 Edit Toolbox

Select the Pointer tool when you want to be able to select and mark objects on your page. Note also the Button tool to help
you draw a button on the page, and the Sound Tool that will help you to add sound to a button.

This is the Font toolbar. Use it to control what text looks like.

Figure 2.4 Font Toolbar

This is the Appearance toolbar, controlling colors, line width and the like. Note especially the tools that allow you to choose
button shape and gradient fill if you draw custom buttons.

Figure 2.5 Appearance Toolbar

This is the Grid Page toolbar. Note the two first tools. Select the first to turn on or off an automatic grid of buttons. Select
the second and then drag a colored area to indicate how many buttons you want.

Figure 2.6 Grid Toolbar

In the bottom right-hand corner of Communicator you can regulate the Zoom level of the page you are working with, either by
selecting the plus and minus buttons or by dragging the glider to zoom in or out.

If you zoom while a button is selected, this button will be the focus point when zooming. If no button is selected, you will zoom
to the center of the page.
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The zoom level is shown in percent next to the minus button. Select the zoom percentage to open the Zoom dialog.

Figure 2.7 Zoom

Figure 2.8 Zoom Dialog

In the Zoom dialog you can zoom to Actual Size, Fit to Window or use Custom Zoom.

2.5 Right-Click Menus
For your convenience, frequently-used commands are available on two right-click menus in Edit view. The commands in these
menus are documented elsewhere.

You can right-click in the Page List for this menu. Commands that apply to a specific page will apply to the currently se-
lected page.

Figure 2.9 Right-click in the Page List
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Right-click in the work area for the menu shown below. Note that commands you give about buttons will apply to the cur-
rently selected button or buttons.

Figure 2.10 Right-click in the work area

2.6 Position and Size
Position and Size is found on the Button menu under Format Object > Position and Size. In this dialog you can change
button size or button position.

Figure 2.11 The Position and Size dialog on a freenhand page for printout

The measurements are given in points if the paper is optimized for screen, and inches/centimeters if you have se-
lected a freehand page for printout.
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3 Basic Page Set Creation
3.1 Making Pages
Communicator is a powerful tool for creating your own communication pages.

To create a new page, select one of the following ways:

• Normal way

1. Open the Quick Menu by selecting Right clicking the mouse or selecting the Menu button on the I-Series(+)
device.

2. Select the (Create New Page Set) button

• From Edit View

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. File > New

or

1. File > Open

The New Page Set window is displayed. This dialog will help you create new pages either for screen view or for printing, and
here you can open and edit device templates, activity templates, your previously created page sets and all the page sets that
are included in Communicator .

Figure 3.1 New Page Set

The New Page Set window is displayed when you choose to open or make a new page set in Communicator .

3.1.1 Creating pages for screen or paper

Select File > New to create a new Page Set. Before you start creating a page set, you should have a clear idea of how you
want to use it. Will it be displayed on a dynamic device with a screen, such as a PC or a I-series(+) device, or do you intend to
print it on paper?

On the left side of the New Page Set dialog there is a list of available actions. Under Create, you can select to create a Blank
Page Set, or you can create a page set based on a Device Template or an Activity Template. When you select Blank Page
Set, you have four options available; you can create a grid page or a freehand page, and it can be prepared for a screen view or
for printing.
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Grid Page for Screen: Select this option when you want to create a standard communication page for a dynamic device. You
can select how many rows and columns you want on your grid page before you select OK, but you can also change this later
using the Grid Page Toolbar.

Freehand Page for Screen: Select this option if you want to place buttons randomly on a page intended for use on a dynamic
device.

Grid Page for Printout: This option adds a predefined grid to a page that is optimized for printing. You can select how many
rows and columns you want on your grid page before you select OK, but you can also change this later using the Grid Page
Toolbar.

Freehand Page for Printout: Select this option if you want to place buttons randomly on a page intended for printing.

3.1.2 Opening existing page sets

Select File > Open to open an existing page set in Communicator .

One the left side of the New Page Set dialog there is a list of available actions. Under Open, selectMy Page Sets to view
and open page sets you have created and saved to your computer underMy Documents > Communicator 5 > User name
> My Page Sets. From the New Page Set dialog you can also Browse to page sets saved to other locations than the My
Page Sets folder.

3.1.2.1 Creating and Naming Pages

Page sets created from the New Page Set dialog only contain one page, but you can add as many pages as you please to any
type of page set.

1. To add a page, right-click in the page list and select New Page.

Figure 3.2 Add a new page to a page set.

2. The new page will have exactly the same setup as the page it was created from; same print or screen optimization, and
same grid layout.

Pages are automatically named when you create them (page 1, page 2).
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1. To give your page a more meaningful name, select Page > Page Properties.

2. Fill in a name on the first tab, General.

Figure 3.3 Page Properties

You may rename pages if you wish.

3. Select OK.

4. You'll see the new name in the Page List.

3.1.3 Page List

Pages are shown in the Page List, at the left of the work area beneath the Edit Toolbox.

• To bring the Page List to the front, select on its tab.
• If you don't see the page list at all, select View > Page List.

Figure 3.4 Page List tab on left side of work area.
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3.1.3.1 Deleting Pages

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. In the Page List, select the page you want to delete.

2. Select Page > Delete Page.

See also:

3.3 Making Buttons With A Grid, page 15

5.1 Page Background and Other Useful Page Properties, page 36

5.9 Organizing Pages, page 50

6.8 Using Pop-up Pages for User Choices, page 65

3.2 Saving Your Work
You must have the page set showing in Communicator .

1. Select File > Save.
If you've saved the page set before, you are finished now.

2. If this is a new page set, you'll see the standard windows Save As dialog.
Check that you are saving in the correct folder.

3. Enter a file name for the page set, and select OK.

Figure 3.5 Saving in My Page Sets simplifies finding things later.

See also:

4.9 Finding Your Page Set Later, page 32

3.3 Making Buttons With A Grid
Applying a grid allows you to make lots of neat, squarish buttons easily. Grid buttons automatically adjust their size to fill the
page.

If you want to create and position buttons a little more slowly and but with more freedom of choice, see 5.2 Drawing Custom
Buttons, page 37.

3.3.1 Adding Buttons by Applying a Grid

Make sure you are in Edit view, and the page showing in the work area is the one where you want to add buttons.

1. Select Page > Apply Grid.
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Or select the Apply Grid tool in the Grid Toolbar:

2. Communicator makes your page into a grid page. A grid page always fills itself with some number of neat, squarish
buttons.

3. To change the number of buttons, select on the Grid Size tool.
A white mini-grid appears.

4. Move the mouse pointer down and right over the mini-grid. Colored grid squares appear to indicate how many buttons
you want.

Figure 3.6 Indicating the grid dimensions.

5. Select in the mini-grid when you are satisfied.

6. Select File > Save to save your page set.

3.3.2 More Grid Tools

Figure 3.7 Tools for adding and removing columns and rows in your grid

To get more or fewer buttons, you can also add or remove rows and columns. Use the remaining tools in the Grid Toolbar, or
use the menu commands under Page > Change Grid.

Figure 3.8 Tool for changing button spacing

Use the last tool on the Grid toolbar to change the spacing of the buttons.

You can also change the spacing with the menu command Page > Page Properties. Choose the tab Grid page, and adjust
the value for spacing.

3.3.3 Rearranging Buttons on a Grid

Once you've added content on your grid buttons, note that you can use the mouse pointer to drag grid buttons around on the
page if you want to rearrange them.

3.3.4 Removing All the Buttons From a Grid Page

To remove all the buttons, change your page back to a regular page:
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• Select Page > Apply Grid again.
• The check mark will be removed from the Page menu, indicating that this is now a freehand page.

Now you'll be able to select and delete all of the buttons.

3.4 Adding Buttons by Duplicating
This technique is good if you want to fill a page with buttons that aren't rectangular, or if you don't want to fill a whole page the
way grid does.

3.4.1 Adding A Single Button to Duplicate

Make sure you are in Edit view and the page showing in the work area is the one where you want to add buttons.

1. Select the Button tool in the Edit Toolbox.

Figure 3.9 Add button tool

2. Note how the mouse pointer gets "loaded" with a button: The pointer changes shape to a cross hair with a button.

3. Point to where the upper left corner of the button should be.

4. Press and hold the mouse button while you drag the pointer towards the lower right corner of the desired button.

Figure 3.10 .Creating a Button with a Mouse

5. Release the mouse button.
You see your new button. It is selected.

3.4.2 Duplicating a Button

Use the Duplicate Objects tool from the Toolbox to make and position many copies of a custom button.
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1. On a blank page, draw a single button in the upper left part of the page. (See Figure 3.10 .Creating a Button with a
Mouse, page 17.)

Figure 3.11 Change Button Shape in the Appearance Toolbar.

2. Select the new button. (Remember to change to the Pointer tool).

3. Choose the Duplicate Objects tool from the Toolbox.

Figure 3.12 Duplicate objects tool

4. Point in the center of your new button and hold the mouse button down.

5. Drag to the opposite corner of the page and release the mouse button.
Your page is filled with copies of the first button.

Figure 3.13 Result of using Duplicate tool.
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You can also drag straight across to make a single row of buttons, or drag vertically for a column.

See also:

5.2 Drawing Custom Buttons, page 37

3.5 Selecting What to Work With in Edit View
When you work in Edit view, keep an eye on the selection markings.

They show you which object your next command will apply to (if you give a command or select a tool that can makes sense for
this object.)

3.5.1 Having Trouble Selecting?

• Are you in Edit view? Press SHIFT+ F5 if you're not sure.
• What tool is selected in the Edit Toolbox? Switch to the Pointer tool and try again.

Figure 3.14 Use Pointer tool to select.

3.5.2 Selecting The Page Canvas

To select the page canvas, select on the grey part of the work area.

• When the page canvas or background is selected, you see little black selection handles around the lower right corner,
like this.

Figure 3.15 Page background or canvas is selected.

• When the page canvas is selected, you can choose a color for it from the Appearance toolbar.
• You can also drag one of the selection handles to resize the canvas. If your page is a pop-up page, the canvas size will

determine pop-up size. For any other page, changing the canvas proportions changes page appearance, but the page
will always stretch to fill the full window or screen where it runs. See 4.8 Running Your Page Set, page 31.
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3.5.3 Selecting An Object on the Canvas

To select a button, use the Pointer tool to select it.

Figure 3.16 Pointer tool.

A selected object has both red selection markings, and small black selection handles.

Figure 3.17 Selected Button

It should be easy to see which of the four buttons has been selected.

• When an object is selected, drag on the selection handles to resize it.
• Give commands from the Menu Bar, choose in the Appearance toolbar, or choose tools in the Edit Toolbox to modify

the selected object.
• Point in the center of the object and drag to move the object.

You can also select a static text, picture or line that rests directly on the canvas. We call them "static" because these objects
just sit there when the page set runs: The user can't press or select them, and they can't perform actions.

3.5.4 Selecting Several Objects

Here are three ways to select more than one object:

• Hold the SHIFT key down while you select additional objects.
• Select Edit > Select All to select every object on the page.
• If the objects you want are close together, point outside any object and begin to drag. You'll see a dotted line (lasso) de-

fining the area for selection. Drag to the diagonally opposite corner, until all the objects you want to work with are
selected.

3.5.5 De-selecting Part of a Group

To de-select one object while leaving others selected, hold the SHIFT key down while you select the object to de-select.
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3.6 Using Standard Editing Commands
While you are working on your pages, you'll probably be glad to have these standard Windows editing commands:

Edit > Copy (CTRL+C) Places a copy of the selected item or items on the Windows
clipboard, ready for a Paste command. Note that this repla-
ces whatever was on the clipboard before.

Edit > Cut (CTRL+X) Removes the selected item or items from the page and pla-
ces them on the Windows clipboard, ready for a Paste com-
mand. Note that this replaces whatever was on the clipboard
before.

Edit > Paste (CTRL+V) Puts whatever was last placed on the Windows clipboard
onto the current page.

Edit > Undo (CTRL+Z) Reverses your last action if possible.

Edit > Redo (CTRL+SHIFT+Z) Repeats your last action if possible.

Edit > Delete Removes selected item or items from the page without
changing what is on the clipboard.
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4 Adding Content
4.1 Adding Content Quickly
In the picture search tab, you can find and add pictures from the installed picture libraries, or photos saved on your computer or
a portable disk, to buttons on the page, or to the page background.

4.1.1 Adding a Picture to a Button

1. Make sure the Picture Search tab is active and displayed on the right hand side. You activate the Picture Search tab
by selecting the Picture tool in the Edit Toolbox.

2. Enter your search in the Search for field. As you type, the most relevant matches are displayed in the search pane.

3. Your search results are sorted by relevance. Exact matches appear first, followed by matches that start with or contain
the search term.

4. Select the picture you want to use.

5. Select Apply. The picture is added to the button and the next button on the page is selected.

Figure 4.1 The Picture search tab in Edit View

The picture is added to the button, and the next button on the page is highlighted.

For information on how to add multiple pictures on buttons, See 4.2 Adding Multiple Pictures to a Button, page 24

Your search results will remain in the search result box until you carry out a new search.

6. If you have checked the Apply picture text box, the picture name will be added to the button together with the picture.
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4.1.2 Hiding the Picture Search Pane

The Picture Search pane is always active and visible when you go to Edit View. You can deactivate it by selecting the Insert Pic-
ture button in the Edit toolbox or the X i the corner of the search pane, or you can choose to hide it by selecting the Auto Hide
pin.

The pane is then replaced by a tab on the right side of the screen, and the page in Communicator is stretched. When you select
the Picture Search tab, the search pane opens and you can use it as normal. If you select anywhere else on the screen, the
pane is reduced to a tab again. Select the Auto Hide pin once more to place the Insert Picture pane back on the side bar. The
pane will also return to it's original position if you deactivate and reactivate the Picture Search button in the Edit Toolbox.

4.1.3 Search Settings

Select Settings... to change your search settings.

If you check Include category matches the search result will also display pictures that belong to a category with a name that
matches the search text. Category matches are listed at the end of the search results.

You can also select if you want to use color pictures, or black and white pictures.

4.1.4 Using a Picture From a File

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select a button and select Browse in the Picture Search tool.
You see the standard Windows Open dialog:

Figure 4.2 The Open dialog

2. Select a folder containing pictures, select the picture you want, and select Open.

3. The picture is inserted on your button.

4.1.5 Using the Free Positioning Tool

With the free positioning tool you can move and resize the text and picture on a button.

1. Select a button containing a picture

2. Select the Free Positioning tool

Figure 4.3 Free positioning tool

3. A dotted square is drawn around the picture and you can move and resize it with the mouse cursor
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4. Select Edit > Undo to go back to the original positioning to the picture.

4.1.6 Removing a Picture

You can remove a picture from a button.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select the button.

2. Select Button > Remove Picture.

4.2 Adding Multiple Pictures to a Button

4.2.1 Adding Multiple Pictures to a Button

Follow this procedure to add a second picture to a button:

1. Select the button where you want to add another picture.

2. In the Picture Search tab, select the picture you want to add and select the arrow next to Apply. Select Add in the
drop down list.

3. The picture is added to the button and both the new and the existing picture are in a floating position. You can move and
resize the pictures as you like.

Figure 4.4 Adding multiple pictures to a button

4. Continue this procedure to add more pictures to the button.
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4.2.2 Adding Multiple Texts to a button

It is also possible to add more than one text to a button. You can achieve this by using the Static Text Tool to drag a new static
text object onto the button.

For more information how to use the Static Text Tool, see 5.4 Text or Picture, page 39.

4.3 Putting Text on Buttons
If you just want to add or edit text on one or more buttons, the Text tool is quickest. It automatically selects just the text on each
button. When you press Enter, you exit the text tool. If you press Tab, the text cursor moves to the next button.

4.3.1 Adding or Changing Text with the Text Tool

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select the button you want to work with.

2. Either select the Text tool, or simply start writing, and your text will be added to the selected button. If no button is se-
lected, the text will be added to the first button on the page.

3. Use the Undo tool or press Esc if you accidentally deleted text on a button.

4. Press Enter to exit the Text tool and keep the new text. The button is still highlighted.

5. Use Tab to move to the next button on the page with the Text tool still active.

6. When you are satisfied with all the buttons, select File > Save to save your page set.

4.3.2 Changing Text Appearance

Text appearance is controlled in several places:

• The Font toolbar controls what you'll change most often, except for
• Text color, which is determined by Appearance toolbar.
• Give the command Button > Text Properties to see additional choices for text on buttons.

All the text in one static text or on one button will have the same appearance

When you create new text, its appearance is determined by the choices currently displayed on the Font toolbar and the Appear-
ance toolbar. You can use the same two toolbars to change what a selected text looks like.

4.3.2.1 The Font Toolbar

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

If you don't see the Font toolbar, select View > Font toolbar.

Figure 4.5 The Font toolbar

4.3.2.2 How To Change Text Appearance

1. Select the text, button or buttons to work with. (See 3.5 Selecting What to Work With in Edit View, page 19)

2. Make a choice on the Font toolbar. In order, your choices are:

• Font
• Font size
• Bold text
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• Italic text
• Underlined text
• Position text at top of button (over picture, if picture)
• Position text in middle of button (will be under picture, if picture)
• Position text at bottom of button.

4.3.2.3 The Appearance Toolbar

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

If you don't see the Appearance toolbar, select View > Appearance toolbar.

Figure 4.6 The Appearance toolbar, text color tool selected

4.3.2.4 How To Change Text Color

1. Select the text, button or buttons to work with. 3.5 Selecting What to Work With in Edit View, page 19.

2. Select the text color tool.
A color palette drops down.

Figure 4.7 Undocked Text Colors

This color palette has been undocked, that is, dragged away from the toolbar to remain open and float over the work
area. It also shows a custom color palette for pastel colors at the top.

3. Select the text color you want.

See also:

5.8 Choosing A Color Palette, page 48

4.3.2.5 Setting Text Alignment, Wrapping and Offset From Button Edge

There are some alignment choices for text on buttons that you rarely change. These are collected in the Text Properties dialog.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select the buttons you want to set properties for.

2. Select Button > Text Properties.
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You see Text Properties dialog:

Figure 4.8 The Text Properties dialog

3. To Left or Right align button text instead of the automatic Center alignment, choose Custom text position, and then
choose a new alignment under Horizontal.
If you have chosen Custom text position, the Vertical alignment chosen here will also apply. (Vertical alignment the
same property you choose with the last three buttons in the Font toolbar.)

4. For a bigger margin between the edge of the button and the text, set the offsets. The units are relative: set a larger num-
ber for a bigger margin. Offset right determines the side margins on the button. Offset down determines the top and
bottom margins. Text will stay inside the margins as far as possible.

5. CheckWrap text and Cut text to ensure that text is displayed only on the button. Otherwise if there is too much text it
will overrun the button and be displayed on the background or across neighboring buttons.

6. Select OK.

Your choices will apply to any buttons that were selected when you gave the command, and to all new buttons created from
now on.

4.4 Putting Sound on Buttons
This section covers how to use the Sound tool in the Edit Toolbox to add sound to a button using synthesized speech, recorded
sounds or sound files that are already present on your computer.

4.4.1 When to Use Sound

For users who cannot speak, the therapist can create buttons that, when pressed, produce words, phrases or other sounds.

For users who cannot not read text, the therapist can use sounds as audible cues. That is, when the user points at the button,
the button will "say something" to indicate which button it is. For visually impaired users see also Read as You Type, in the
Settings > Sound Settings dialog.

4.4.2 Adding Sound to A Button

You can add sound to a button in Run view with the Edit Button Wizard. To use the Sound dialog described here, you must be
in Edit view.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.
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1. Select the Sound tool in the Edit Toolbox.

Figure 4.9 The Sound tool

The Button Sound dialog opens.

Figure 4.10 The Button Sound dialog.

2. Select the button you want to modify, or select Next button >> until the preview shows the button you want to change.

3. Choose the kind of sound you want to use.

• Synthesized speech: Can only be used to read button text or a text you type in: You have to tell it what to say.
• Recorded sound: Communicator will search the sound library for a recorded sound with a name that exactly

matches the button text (or the specified text under Text to speak), and play the sound in that file. To use this feature
you will have to name your recorded sounds to match the spoken text. If there is no sound matching the text on the
button, you can select Record Sound to add your own sound for this text. Note that you need a working micro-
phone to record new sounds.

• Play this sound file: No sweat about matching names, just choose the file name that has the sound in it. Of
course, you have to know where the sound file is stored on your computer. (Avoid this option, or keep all sound files
in a folder within My Page Sets if you are planning on copying this page set to other computers.)

4. If you've chosen Synthesized speech, then choose a text to speak.
For the button shown in the illustration, if you choose Speak text on button, the computer will say blue when the but-
ton is pressed.

If you choose Speak this text, you might type something likeWhat color is this? This color is blue.

5. If the button has actions to carry out, for example, linking to another page, you may want to checkWait until finished.
Button action will not begin until sound is finished. Otherwise, the user may not even see this button while its sound is
playing.

6. Select Save to keep your changes to this button.
If you intend to work with several buttons, you may want to check Use Save and go to next. Each time you select
Save, the dialog will both save your changes and display the next button.

7. Select Close when you are finished.

8. Select File > Save to save your page set.

See also:

4.1 Adding Content Quickly, page 22

28 4 Adding Content Making Your Own Page Sets Reference manual v.1.0 - en-US



4.5 Putting Video on a Button
In Communicator there is the option to let a button run a video. The video can run within an area defined by the size of the but-
ton, or it can run full screen.

If the user presses the button again while the video is running, the video will stop (not pause). A new press will start the video
again from the beginning.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select the button to have a video.

2. Select Button > Video.
You see this dialog.

Figure 4.11 The Video Properties dialog

3. Select the Browse button.

4. You see the standard Windows Open dialog.

5. Select a video file located on your own PC. File type can be AVI, MPEG, MPG, or MPE.

6. Select Open.

7. In the Button video dialog, choose how the video should be played.

8. Select OK.

4.6 Assigning a Keystroke to a Button
If you want to hit a keyboard key to activate a button while the page set is running, you can assign a keystroke to the button.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select a single button.

2. Select Button > Assign Keystroke.
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You see this dialog:

Figure 4.12 Assign Keystroke

A button can be activated by pressing a key on the keyboard.

3. In the drop down list, choose a key.

4. Select OK.

When the page sets runs, pressing the keyboard key you chose will be the same as pressing the button with any other user in-
put method.

4.7 Setting the First Page
If your page set has more than one page, you need to consider which page the user will see first, and how the user will get to
the other pages.

Any regular page in the page set can be turned into the first page. Pop-up pages, however, cannot be chosen as the first page.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. In the Page List, choose the page you want to be the first page.

2. Select Page > Set as First Page.
In the page list, the page you chose moves to the top of the list and is marked as the first page:

Figure 4.13 Set First Page

First page moves to top of page list

See also:

3.1 Making Pages, page 12

5.9 Organizing Pages, page 50
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4.8 Running Your Page Set
To run your page set, select the Run tool on the Standard toolbar.

Figure 4.14 The Standard toolbar

Alternatively, you can select View > Run, or press F5.

4.8.1 Deciding How the Page Set Will Run

Your page set can run covering the full screen, or it can run in a window of any size, including a maximized window.

• Choose Full Screen for a user who might accidentally select outside of a window, and be unable to recover.
• Choose Full Screen for a user who needs the simplest possible screen to relate to.
• Choose Run in Window if you want the page set to cover only a part of the screen. This might be suitable for an on-

screen keyboard, or a display created to allow the user to interact with some other program.
• Choose Run in Window if you'd like the option to have the Menu Bar available while the page set runs.
• Choose Run in Window if you need to be able to move the page set around on the desktop.

4.8.2 Using the How to Run Tab

You can always set your choices for how the page set will run, whether you are in Run view or Edit view.

1. If you don't see the Menu bar, press SHIFT + F10.

2. Select File > Page Set Properties.
You see this dialog:

Your choices here determine how the page set will run.

You will be adjusting the settings on the first tab, How to Run.

3. From the Run in section, chooseWindow view or Full screen view.
If you chose Full screen, skip to step 8.

4. If you chose Window View, choose Window position.

• Fixed position will always open the page set window with the same size and position. The size or position is set
by example: Close this dialog, run the page set, adjust size and position the way you want them, and then open this
dialog again and select Use Current Position.

• Docked position allows you to place a small page window along the edge of the display. Here the size is set as a
percentage of display size with the Width and Height fields. Pick the edge to dock against and the part of the edge
(end or middle) to use with the Vertical and Horizontal fields.

5. If you chose Window View,Window style choices control how much flexibility the user has when the page set runs.

• Show title bar The page set can be moved while it is running, by dragging the title bar.
• Show window border The page set can be resized while it is running, by dragging the window border or corners.
• Show program (command) menu The Run view Menu Bar, an abbreviated version of the Edit view menu bar, will

be visible while the page set runs.

In Run view, press F10 to turn all three options on. Press F10 again to return to the settings saved in this
dialog.

6. If you chose Window View, also considerMiscellaneous choices.

• Always on topOther windows will not be able to cover up the page set. Secures a user who may not be able to re-
stack windows if the Communicator page set gets lost.

• Allow interaction Lets the user give menu commands to another Windows program when the page set contains
an on-screen keyboard.

7. Transparency makes the page set partially see-through, so that user can keep track of what the page set is covering
up. Often a good choice when a small page set is docked. This is not normally a good choice for users who need Full
Screen mode.
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8. Select Ok.

9. Select File > Save to save your page set.

Figure 4.15 Three different ways to run the page set in a window.

A. Docked, without Title bar, Menu Bar or Windows border.

B. Even if you choose Docked, if you leave the Title bar on like this, the page set can be moved.

C. With Border on, the page set can be re-sized while it is running. Press F10 to put the page set in this state, with the Title
bar, menu and border all turned on. Press F10 again to return to the settings from the dialog.

4.9 Finding Your Page Set Later
To return to a page set you have exited, you will need to open the page set again.

If you have saved in the folder suggested by Communicator, your page sets will usually be located in the folder
My Documents > Communicator 5> User name > My Page Sets. (If you have created several Communicator users and
stored page sets for different users, substitute the appropriate user name for User name.)

If you have chosen a different folder to save in, we have to assume that you know how to find it again. These instructions cover
the default situation.

4.9.1 Open a Recently Used Page Set

1. If your user is always Guest, skip to step 3.

2. If you have created several users, make sure that Communicator is set to the correct user for the page set you want to
retrieve. To change the user, use the menu command Settings > Users > Change User and select the appropriate
user.

3. Select File to open the File menu.

4. Look at the files listed at the bottom of the menu. If you see the file you want, press the appropriate file name.

If not, choose the Open command.

4.9.2 Opening a Page Set with File > Open

1. If your user is always Guest, skip to step 3.

2. If you have created several users, make sure that Communicator is set to the correct user for the page set you want to
retrieve. To change the user, use the menu command Settings > Users > Change User and select the appropriate
user.
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3. Select File > Open.
You will see the New Page Set dialog.

Communicator will suggest the defaultMy Page Sets folder for the current user.

Opening a page set from the default folder.

4. Select the page set you want to open, and select OK.

4.10 Linking Pages Together
In any page set with more than one page, you will need to make some buttons for the purpose of moving from page to page.

You can put whatever picture, text or sound on these buttons that you like, but they must also contain an action: A link to anoth-
er page. You can also create links to pages in different pages sets, if you wish.

This section covers how to link pages. For other kinds of actions, see 6.1 Adding Actions and Smart Behavior, page 53.

4.10.1 Button Templates for Links

Some of the most common links are available as Button Templates. These include Back, Home and Next / Previous. See 6.2 Us-
ing Button Templates, page 55.

4.10.2 Linking to a Page in the Same Page Set

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

To create Links, follow these steps:

1. Select the button the user will press to change pages.

2. In the Edit Toolbox, select the Link tool.

Figure 4.16 The Link tool
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You see the Link Tool dialog.

Figure 4.17 The Link dialog for buttons that go to other pages.

3. Choose Go to page and select the Select... button
You see the Select Page dialog:

Figure 4.18 Select Page Dialog

Choose the page to move to.

4. Select the thumbnail of the page to link to.

5. Select OK in the Select Page dialog.

6. Select OK in the Link Tool dialog.

7. Select File > Save to save your page set.

4.10.3 Models for Linking Page Sets

In a simple page set with a few pages, each page links to all the others.
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Here is a sketch of a page set with 4 pages. Each page has the same column of buttons for changing pages.

An advanced user often has multiple page sets. Some of them are activated from the Home page, and some page sets activate
others. In this case it is often wise to equip every page or page set with Go Back and Go Home buttons.

See also:

6.8 Using Pop-up Pages for User Choices, page 65

9.3 Link Visualization, page 80
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5 Controlling How it Looks
5.1 Page Background and Other Useful Page Properties
The Page Properties dialog collects information and choices that apply to each individual page.

• For a freehand page (one without a button grid) note that you can control the positioning dots with the Freehand Page
tab in this dialog.

5.1.1 Putting a Picture in the Background

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. In the Page List, select the page you want to work with.

2. Select Page > Page Properties.
You see the Page Properties dialog:

You can choose background color or picture here.

3. Select the Background tab.

4. To choose a background color, select the white square under Click to select background color and select a color
from the Color dialog that pops open. You can also select if you want to use flat or gradient color.

5. To choose a picture file on your PC, select the Browse button.

6. Locate your picture file with the standard Windows Open dialog, and select the Open button.
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Back in the Page Properties dialog, you see a preview of the picture you have selected:

Once you choose a picture, you see a preview.

7. Try checking and un-checking Stretch Picture to see what gives the most satisfactory results.

8. When you are finished, select OK.

The picture you selected is placed on the page canvas. It is behind any object you put on the page, and you will not be able to
select it.

5.1.2 To Remove a Background Picture

1. Select the page and go to the Page Properties dialog, Background tab as described above.

2. Select the Remove button.

5.2 Drawing Custom Buttons
If you want to control button shape and position, don't apply a grid to your page. Leave it a freehand page, and draw your own
buttons and push them around the screen any way you want!

5.2.1 Drawing a Button

Make sure you are in Edit view and the page showing in the work area is the one where you want to add buttons.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select the Button tool in the Edit Toolbox.

Figure 5.1 The Add button tool

Note how the mouse pointer gets "loaded" with a button: The pointer changes shape to a cross hair with a button.

2. Point to where the upper left corner of the button should be.
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3. Press and hold the mouse button while you drag the pointer towards the lower right corner of the desired button.

Figure 5.2 Drawing a button.

4. Release the mouse button.

You see your new button. It is selected, ready for your next command.

5.2.2 Appearance Toolbar Formats All New Buttons

When you draw a new button, its appearance is determined by the settings on the Appearance toolbar.

The Appearance Toolbar

5.3 Copying Button Appearance
Suppose you've made a lovely button. And now you want seven other buttons to look the same. It's easy.

5.3.1 How to Make Buttons Look Alike

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select your model button. It should be the only button selected.

Figure 5.3 Select the model button.

2. Select Edit > Copy.
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3. Select your target button, or buttons. For how to select several, see 3.5 Selecting What to Work With in Edit View, page
19.

Figure 5.4 Select the target buttons.

4. Select Edit > Paste Special > Appearance.

Figure 5.5 Three similar buttons.

5. The target buttons take on the shape, border, and fill of the model you copied.

5.4 Text or Picture
Buttons may show text and pictures, but buttons are intended to be pressed.

If you just want to put a title on your page, or a picture to decorate or illustrate, use a Static Text or Static Picture. When the
page set runs they cannot be selected, will not be scanned, cannot be pressed. They don't do anything, they just sit there:
Static.

5.4.1 Creating a Static Text

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. In the Edit toolbox, select the Text tool.

Figure 5.6 The Text tool

The mouse pointer changes to a cross hair and rectangle.

2. Just as if drawing a button, start at one corner of the planned text area. Press and hold the mouse button.
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3. Drag to the diagonally opposite corner of the text area and release the mouse button.

Figure 5.7 Static text area looks a lot like a button, but it holds a gray reminder text

The new text area is automatically selected.

4. Start typing your text.

5. Select the Pointer tool when you are done typing or modifying the text.
In Edit view, you see a dashed line around the static text area.

Static text is automatically created with no border and a transparent fill, so that the page background will show through.
Think very carefully before changing these attributes.

When the page set is run, this helps your user to tell the difference between pressable buttons with text on them, and
non-pressable title text.

Figure 5.8 Static text looks like this in Edit view. No border, transparent fill.

You can change text appearance with the Font toolbar and the other tools you use for text on buttons. See 4.3.2
Changing Text Appearance, page 25.

5.4.2 Putting a Static Picture on the Page

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. In the Edit toolbox, click the Picture tool.

Figure 5.9 Picture tool

The mouse pointer changes to a cross hair and rectangle.

2. Just as if drawing a button, start at one corner of the planned picture area. Press and hold the mouse button.
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3. Drag to the diagonally opposite corner of the picture area and release the mouse button.

Figure 5.10 Static picture area looks a lot like a button, but it holds a gray reminder text

4. The new picture area is automatically selected.

5. In the Edit toolbox, make sure the Picture tool is active and the Picture Search pane is displayed on the right-hand side
of the screen.

6. To select a photograph from your PC, click the Browse button.
You see the standard Windows Open dialog:

Figure 5.11 Using the standard Windows Open dialog to choose a picture.

7. Locate the picture and click Open.

8. The selected picture is inserted to the Static Picture button.
In Edit view, you see a dashed line around the static picture area.

The static picture area is automatically created with no border and a transparent fill, so that the page background will
show through. Think very carefully before changing these attributes. When the page set is run, this helps your user to tell
the difference between pressable buttons with pictures on them, and non-pressable, static pictures.

Figure 5.12 A static picture might look like this in Edit view.

5.4.3 Picture on the Background

Pictures on the page background are a pleasant way to personalize a Communicator page set. When you put a picture on the
background, you won't accidentally select the picture when you are trying to select a button.

Keep in mind that visual "noise" in the background might make it difficult for your user to find the buttons, so make sure you pro-
vide good contrast between buttons and background picture.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.
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To put a picture on the background of the page:

1. In the Page List, select the page you want to have a background picture.

2. Select Page > Page Properties.

3. Choose the Background tab.
You see this dialog:

Figure 5.13 Adding or removing a picture on the page canvas.

4. Click Browse.

5. You see the standard Windows Open dialog.

6. Select a picture from your PC.

7. In the Open dialog, click OK.

8. In the Page Properties dialog, click OK.

5.5 Editing a Picture

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

If you want to, you can edit pictures or draw your own with the Edit Picture Tool.

5.5.1 Editing a Picture

1. Select a button with a picture.

2. Select the Edit Picture tool in the Edit toolbox.

Figure 5.14 The Edit Picture Tool
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3. The Edit Picture Tool dialog opens and the selected picture is displayed.

Figure 5.15 The Edit Picture Tool Dialog — Edit Picture

4. Select the tools at the top and left side of the dialog to edit the picture.
On the right side of the dialog you can adjust zoom level and pan in the picture.

5. Select OK when you are finished, or select Cancel to exit the tool without applying your changes.

5.5.2 Drawing a Picture

If you have selected a button without a picture and select the Edit Picture tool, you can draw your own pictures.

1. Select an empty button.

2. Select the Edit Picture tool in the Edit toolbox.

3. The Edit Picture Tool dialog opens and instead of previewing an existing picture you can create one.

Figure 5.16 The Edit Picture Tool Dialog — Create Picture

4. Select the OK button in the middle of the dialog. A blank button is previewed, and here you can draw your own picture
with the tools available.

5. Select OK when you are finished, or select Cancel to exit the tool without creating the picture.
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5.6 Keeping Things Neat With Layout
The commands in the Layout menu help you to give your pages a smooth, professional look. You can use the Layout menu to
standardize button size, position and spacing. You can lock button position, stack buttons and other elements, and determine
how buttons will interact with the alignment grid dots.

5.6.1 Aligning Buttons or Matching Button Size

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. In the Edit toolbox, choose the Pointer tool.

Figure 5.17 The Pointer tool

2. Select all the buttons that you want to align or resize.
You must select at least two buttons to align or resize.

To select several buttons, select the first button, and then hold down SHIFT while you select each additional button. Or,
hold the mouse button down while you drag a selection lasso around all the buttons as shown in Figure 5.18 These but-
tons need Layout commands to straighten up.

Figure 5.18 These buttons need Layout commands to straighten up.

3. Give a menu command from the Layout menu
Communicator picks one button and aligns or resizes the others to match. It might not be the same button you had in
mind as "model." After alignment or resizing, there is still a single set of selection handles that applies to all of the
buttons.

4. To adjust the position of the whole selected group: Put the Pointer tool in the center of a button, and hold the mouse
button down while you drag left or right. This will move all of the selected buttons together.

5. To adjust button size throughout the selected group: Put the Pointer tool on one of the selection handles, and hold the
mouse button down while you drag. This will resize all of the buttons identically.
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5.6.2 Spacing Buttons Evenly

1. Move the first and last buttons into approximate position.

2. Select the entire group to be spaced evenly. (For selection tips, see above.)

3. Give menu commands to align or resize the buttons if you wish.

4. Select Layout > Space Evenly > Across to make an even row of buttons.
Select Layout > Space Evenly > Down to make an even column of buttons.

5.6.3 Stacking with Bring to Front

You can use the commands Layout > Bring to Front and Layout > Send to Back to arrange items in the desired order when you
find it necessary to stack them.

Here's an example from a page in the ready-made page set Memory. Notice how the game developer has used a static text on
top of a regular, text button. The Bring-to-Front and Send-to-Back commands help you to get the desired result in when you do
something like this.

Figure 5.19 Selection markings show that each button is composed of two elements.

5.6.4 Lock Position

Once you have things exactly where you want them, consider giving the command Layout > Lock Position to prevent accidental
movement.

Locked items have a small lock icon in Edit view:

Figure 5.20 Buttons with locked position.

To remove the lock select the object(s) and select Layout > Lock Position again.

5.6.5 Layout > Align > Snap to Grid

If your buttons have gotten slightly out of line, it may help to select a group of them and give the command Layout > Align >
Snap to Grid. The buttons will move as necessary to line up with the alignment grid.

The alignment grid is represented by the dots you see across the page when you are in Edit view. To set the spacing of these
dots, select Page > Page Properties and choose the Freehand page tab.
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5.7 Invisible and Non-selectable Buttons

5.7.1 Why Hide a Button?

Therapists sometimes create extensive Communication pages for users who are not yet ready to take advantage of all of the
buttons. The Hide Button action allows the therapist to hide buttons until the user is ready for them. Then it is very easy to reveal
the additional buttons - which may even lead to additional pages.

When you hide a button the button cannot be selected (overriding the non-selectable property).

5.7.2 Making a Button Invisible

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select the button(s) you want to be invisible.

Figure 5.21 Here we are going to Hide the 5 of the six circled buttons.

2. Select Button > Hidden.

3. The command is marked in the menu - this is the only way you can see that the button has been hidden when you are in
Edit view.
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4. Run the page set. The button will no longer be visible:

Figure 5.22 The buttons are still here, but now they are hidden in Run view.

5.7.3 Making a Button Non-selectable: Help Scan Users

You can also make buttons that cannot be selected.

Why would you? Well, the smart buttons described in 6.1 Adding Actions and Smart Behavior, page 53 are sometimes present
merely to display updated information, for example the number of unread e-mails. Nobody needs to press them, and scan users
certainly don't need to wait while such buttons are scanned.

The Hidden property overrides the non-selectable property. Hidden buttons can never be selected in Run View.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

To make a button Non-selectable, follow these step:

1. Select the button you want to work with.

2. Select Button > Non-selectable.
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3. The command is marked in the menu - this is the only way you can see that the button is non- selectable when you are in
Edit view.

How to spot a non-selectable button.

See also: Support for Scanning Users

5.8 Choosing A Color Palette
In order to give an attractive, professional visual impression you may want to plan and limit the colors you use for buttons, texts
and page backgrounds within a page set, or a group of page sets.

5.8.1 Basic And Custom Color Palettes in Communicator

When you select the dropdown on one of the color tools, for example fill color, you see the basic communicator color palette of
40 colors.
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• If you create and select a custom palette, your custom colors will be shown at the top, like this:

Figure 5.23 Customized palette.

• If you have more than one custom palette, choose which one to use with the menu command Tools > Color Palettes.
Or just select the Change/Edit button at the base of the standard palette.

5.8.2 Creating a New, Empty Palette

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select Tools > Color Palettes.

Figure 5.24 The Color Palettes Dialog

Create and fill a new palette here.

2. Select the New button.

3. In the next dialog, type a name for your palette and select OK.
Your new palette is listed under Available palettes, and contains no colors.

5.8.3 Adding Colors to Your Own Palette

You can add and remove colors in a custom palette or in the basic palette.

1. In the Color Palettes dialog explained above, select the palette you want to change.

2. At the right, select Add.
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3. Select Edit to change the color.

4. Select one of the colors to select it.

5. Select OK to add the color to your palette.
You return to the Color Palettes dialog, and you have added one color to your palette.

6. Select Add for an additional color, then select Edit and repeat the color selection process.

5.8.4 Adding a Custom Color to a Palette

You may have noticed that in the instructions above, you were still picking from the same colors as you would find in the basic
palette. If you are making your own palette, you will probably want to define some custom colors.

1. Follow the instructions above, but select Define Custom Colors.

2. The dialog extends with a color picker on the right:

The Extended Color Dialog.

Choose a patch on the left first!

3. Use the right side to select a color: Drag the two black selectors until you see the color you want in the sampling field.

4. Select OK.

5. Back in the Color Palettes dialog, the custom color has been added to the list under Colors in palette.

5.9 Organizing Pages
When you are working with a page set with many pages, you may find this section helpful.

Page order and page groups in the Page List do not change what the user sees when the page set runs. What's important is
what you set as the first page, and what that page links to.

However, you can use the Page Groups command to reorder pages if you want them in a different order in Edit view, and to
group pages to make it easier to navigate in the Page List.
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Here we have added Page groups to the Memory game from the ready-made page sets.

• Group title bars appear in the Page List.
• You can expand or collapse a Page group by selecting the symbol at the left of the group title.

5.9.1 How to Group Pages or Change Order

Every group must have at least one page in it, so don't start making groups until you have created most of your pages.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. With the pointer tool, point anywhere in the Page List and right-click.
You see the Page List object menu:

Figure 5.25 The Page List Object Menu

2. Select Page Groups
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You see the Page Groups dialog.

Figure 5.26 The Group Page Dialog

Use this dialog for groups and for page order.

3. On the right side, select one or more pages to belong to the new group.
If you already have page groups, you may have to choose a group on the left first in order to find the pages you want.

When you have selected a single page from the right-hand list, you can use the arrow buttons to move the
page around, changing page order in the Page List. If changing order is all you want to do, select OK to
close the Page Groups dialog now.

4. To go on and make a new group, select Move to.

5. In the drop down list, choose New group.

6. Type a descriptive name for the new group.

7. Select OK to return to the Page Groups dialog.

8. To make another group, repeat from step 4.

9. When you are satisfied, select OK in the Page Groups dialog.
You see your Page List with the new group titles.
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6 Actions and Smart Behavior
6.1 Adding Actions and Smart Behavior
Add actions to buttons to empower your users.

There are two very basic actions that have been covered elsewhere: Play a sound, see 4.4 Putting Sound on Buttons, page
27, and Link to another page, see 4.10 Linking Pages Together, page 33.

6.1.1 Button Templates

The Button Template list is your shortcut to many popular action buttons and Smart Buttons.

In a nutshell: Select a button that should have the action or Smart Button functionality. Then select the appropriate button name
from the Button Template list. The action, or smart button type and action, that you selected gets pasted into the selected
button.

Look in the lower left corner for the Button Templates.

6.1.2 Action Buttons

Some of the actions you can add to a button include:

• Play, Stop, Pause, Next or Previous Song for a Music Player.
• New, Open, Save or Save As commands for working with text files.
• Write the button text to the Message window or Say the text in the message window for a Communication page.
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Use the menu command Button > Button Actions to put one or more actions on a button, or select the button and then se-
lect a button name on the Button Templates list.

On keyboards, text or symbol-based communication page sets, there is usually a message window button. Many of the other
buttons have a "write to message window" action that will take place when the user presses the button.

6.1.3 Smarter Buttons

Communicator also lets you create Smart Buttons that re-use programmed functionality from the ready-made page sets.

Examples of Smart Buttons are:

• The Message Window, that can receive text or symbols and display a text insertion point (cursor position).
• Keyboard key buttons that both display and write either upper or lower case.
• Buttons that fetch and display information like how many unread messages from e-mail or a mobile phone.
• Match items in the Match Game that know when they match each other.
• Predicted Word Item buttons that automatically change the word they show, based on what the user is typing and the

active dictionary.

You'll find all Smart Buttons in the Button > Smart Button Types dialog.

6.1.4 Smart Buttons and Actions

Many Smart Buttons are typically used with certain actions. For example, a Word Prediction Item Smart Button typically has a
write action.

In Edit view the gear symbols show you that the Word Prediction Item and the Message Window are Smart Buttons.
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In Run view, the button predicts different words all the time, based on what the user is typing.

Like many Smart Buttons, this one figures out its own content. It is never a good idea to put a text or picture on a smart button
until after you have checked what content the smart button generates all by itself!

InRun view when the user presses the Word Prediction Button, the action (write) takes place, and the currently predicted
word, dinner, gets added to the message window.

Each button may have zero or one Smart Button type (never more than one). However, each button can have as many different
actions as you find sensible.

In the Edit toolbox, select the Smart Button Type and Actions tool to see a dialog that will give you an overview of both type
and actions.

Figure 6.1 Smart Button Type and Actions tool

6.2 Using Button Templates
In Edit view, you'll find the Button Templates list on a tab beside the Page List tab, below the Edit Toolbox.

Look in the lower left corner for the Button Templates.
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Button Templates lists some frequently used action buttons, and also some of the frequently re-used Smart buttons from the
ready-made page sets.

Using a Button Template is a lot like giving the command Edit > Paste Special > Actions and Smart Button Type. You get
the actions and Smart Button type (if any) from the template added to your button. Using a Button Template does not determine
button appearance. If the Button Template includes a Smart Button type, it can (but does not always) determine button content,
especially text content.

6.2.1 How to Use Button Templates

You must be in Edit view to apply a Button Template.

1. On the page, select the button where you want to apply the template.
You see selection markings on the button.

Figure 6.2 One button selected on a grid.

2. At the left side of the screen, below the Edit Toolbox, select the Button Template tab to make it visible in front of the
Page List.
If you don't see the Button template tab, select View > Button Templates.

Figure 6.3 Select a button, select a Button template. What could be easier?

To see what actions a template contains, rest the mouse pointer on the template name for a while. A tool tip will appear
with an explanation.
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3. Select the template name on the Button Template tab.
Actions are copied onto the selected button. A Smart Button type may also be copied.

4. For some Smart button types, the button will get a placeholder text. You will not see the actual text until you run the
page set.
With other templates, you won't see any difference in the button at all, and will need to run the page set and try the but-
ton in order to see that the process has worked.

Figure 6.4 Keyboard keys look alike in Edit view

Figure 6.5 The same keys in Run view

6.2.2 Investigating what the Template Did

1. To see what the template has added to a button, select the button and select the Smart Button type and Button Ac-
tions tool.

Figure 6.6 Smart Button Type and Actions tool
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You see the Smart Button Type and Actions dialog:

• Select Change to change Smart Button type
• Select Add to add more actions

Smart Button Type shows which Features tab the button's behavior - often its text and default actions - originate from.
The Actions section shows the action or actions that have been added to the button.

2. Select one of the actions.

3. If the action has properties, or choices you can make about how the action will be carried out, you can see what they are
by selecting Properties.

4. In the case of a Keyboard key, you can choose to have it write its letter in a Communicator Message Window, or in the
currently open window of another Windows program:

Figure 6.7 Expect different dialogs when you add different actions.

6.3 Adding Actions to Buttons
In this section you see how to create your own action buttons.

For example, you would use action buttons to create this larger, more accessible volume control for sounds played through Win-
dows, such as music played with the Windows Media Player:

Action buttons decrease, set to normal level, and increase PC sound volume.
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6.3.1 Creating Action Buttons

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Draw the button or buttons you need.

2. Select one button.

3. Select Button > Button Actions.
You see the Button Actions dialog.

4. At the top, select one of the Features Tabs. For this example, select Sound:

Figure 6.8 The Button Action Dialog

All actions come from one of the Features tabs.

5. On the Sound tab, select the action Set Master Volume, as shown in Figure 6.8 The Button Action Dialog, page 59.
If you do not see the Sound tab, put a check in the box Show all actions at the bottom of the dialog

6. Select Add.
A dialog pops up to ask what volume change you want the button to make.

Adding different actions will give you different dialogs here.

7. Choose whether the button will set a fixed volume, or increase or reduce the volume by one step each time it is pressed.
You can also add an action to turn sound on and off.

8. Select OK.
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The action is added to the button.

Figure 6.9 The Button Action Dialog — Action Added

All actions the button will take are shown in the list at the bottom of the Edit Button Actions dialog. It is very common of
a button to have just one or two actions.

9. Select OK to close the dialog.
You can put any picture or text on the button that makes sense to your user.

10. To test your new action button, press F5 to run the page set.

6.4 Actions on Entering or Leaving Page
A few actions can take place when a page opens, or when the user leaves the page.

For example, you might add a counter to a page to tell the user how many times he has played a game.

• Each time the user leaves the page, you will add 1 to the counter.
• Each time the user returns to the page, you can use a message window to display the new value.

6.4.1 To Associate Actions With the Page

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. In the Page List, select the page to add an action to.

2. Give one of these menu commands

• Page > Page Actions > Page Open Actions
• Page > Page Actions > Page Close Actions.

3. Choose and define actions, as explained in Adding Actions to Buttons.
The main difference is that there are fewer meaningful actions for you to choose from.

You can also define actions that take place when the page set is run or exited. See 6.5 Actions on Running Page Set,
page 61
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6.5 Actions on Running Page Set
A few actions can take place when a page set starts running, or when the user leaves the page set.

For example, if the page set is for a game, you might add an action to store the user's score when he exits the page set, and to
display the previous score when the user runs the game page set again.

Another common usage is to reset input type for the purpose of a special page set. Perhaps your user generally users a switch,
but is practicing with a mouse.

You could make a motivational game to use with the mouse, and set input type to mouse select when the game stars, resetting
input type to switch input / scanning when the user exits the game.

6.5.1 To Associate Actions with the Page Set

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Give one of these menu commands

• File > Page Set Actions > Open Page Set Actions
• File > Page Set Actions > Close Page Set Actions

2. Choose and define actions, as explained in 6.3 Adding Actions to Buttons, page 58.
The main difference is that there are fewer meaningful actions for you to choose from.

6.6 Using Smart Buttons
Smart Buttons are buttons that have configurable functionality in addition to actions.

Communicator lets you create Smart Buttons that re-use programmed functionality from the ready-made page sets.

Examples of Smart Buttons are:

• The Message Window, that can receive text or symbols and display a text insertion point (cursor position).
• Keyboard key buttons that both display and write either upper or lower case.
• Buttons that fetch and display information like how many unread messages from e-mail or a mobile phone.
• Match items in the Match Game that know when they match each other.
• Predicted Word Item buttons that automatically change the word they show, based on what the user is typing and the

active dictionary.

You'll find all Smart Buttons in the Button > Smart Button Types dialog.

Figure 6.10 All Smart Buttons have the little Gear icon in the upper left hand corner.
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6.6.1 So How Do I Make Smart Buttons?

By using a Button Template that happens to be a Smart Button, see 6.2 Using Button Templates, page 55, or by choosing a
Smart Button type for your button using the Smart Button Types dialog:

6.6.2 How Can I Tell If It's A Smart Button Or Not?

1. Select a button - from a Ready-Made Page Set, or one of your own that you've made with a Button Template, see 6.2
Using Button Templates, page 55.

2. Select the Smart Button Type and Actions tool in the Edit Toolbox.

Figure 6.11 Edit Smart Button Type and Actions.
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3. Look at the field beneath Smart Button Type:

You can Change type or Add actions starting from this dialog.

6.6.3 Only One Kind of "Smarts" Per Button

A button can only have one type of smart button functionality: The same button can't be a match item and a play list item, for ex-
ample. Most smart button types have one or more default actions.

However, you can add asmany actions to the button as you find sensible.

6.6.4 Smart Buttons Often Know What To Say

Many Smart Buttons automatically figure out what text to display, so it is never a good idea to put your own text on a smart but-
ton too soon. Run the page set first, and see what the button looks like all on its own, before you decide to put text on it.

6.6.5 Smart Buttons Flock Together

Many Smart Buttons have functionality or actions that only work sensibly if additional Smart Buttons of specific types are there
on the same page.

For example, the Keyboard Keys have as their default action that they send their letter to a Message Window. If you use Key-
board Keys Smart Buttons on a page with no Message Window, then they probably won't work the way you want them to.

6.6.6 Investigating Ready-Made Buttons

There are two ways for you to figure out which buttons to use together:

• Play with the Ready-Made page sets to see how the buttons work together.
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• Select the button and check it out with the Button > Smart Button Type command:

6.7 Making Your Own Smart Buttons
Smart Buttons are buttons that have configurable functionality in addition to actions. You can learn more about Smart Buttons
in 6.6 Using Smart Buttons, page 61.

6.7.1 How to Make A Smart Button

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select a button to work with. You may select several buttons for this task.

2. Select Button > Smart Button Type.
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You see the Smart Button Type dialog:

Figure 6.12 The Smart Button Type Dialog

3. At the top, choose a Feature Tab related to the kind of button you want.

4. In the list box, consider the types of Smart Buttons available.
Select one to read what it does on the right. Notice that different button types have different properties for you to set,
and different default actions.

5. Select the Smart button type you want.

6. Consider and edit your options on the right side of the dialog.

7. When you are satisfied, select OK.

You should now add any other smart buttons that you have understood to be necessary, and try running the page set. Remem-
ber not to add text to a smart button until you see what it is going to do on its own initiative, so to speak, in run view.

6.7.2 Instant Smart Buttons

Some of the Button Templates are templates for Smart Buttons.

• To use a template, select the button to add Smart Button type and actions to, and then select the name of the template.
• Use the Smart Button Type and Action tool to investigate what the template added to your button.

Figure 6.13 The Smart Button Types and Actions tool

6.8 Using Pop-up Pages for User Choices

6.8.1 What is a Pop-up Page?

This volume control page is an example of a pop-up page.

• Like a Windows dialog, when a pop-up page is open, it isn't possible to choose anything outside the pop-up.
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• Like a dialog, a pop-up page only covers part of the page that it started from, which helps most users understand what
is going on.

6.8.2 How to create a Pop-up Page for User Choices

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. In the Page List, select the page that will be the pop-up.
Here we have selected the Volume Page in a TV control page set.

This example happens to have three buttons that send IR signals through a GEWA control to the TV:

Pop-up pages should normally be smaller than regular pages, so that the originating page will show behind
the pop-up in Run view.

You can make a smaller page by selecting the page background to select it, and then dragging the lower right corner se-
lection handle partway towards the center of the page.

2. Select Page > Show as Popup.

3. Go to the originating page, the page that will be visible behind the pop-up.
For this example, the originating page is the main TV page.

4. Select the button that will link to the pop-up page.
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In this example, it is the Volume Button.

Figure 6.14 This is the originating page.

5. Select Button > Link.
You see the Link dialog:

Figure 6.15 The Link Dialog.

6. Choose Go to page, and select the Select... button

7. In the Select Page dialog, choose the pop-up page from the list and select OK.

8. In the Link tool dialog, check Return after one selection.
In this case, that means as soon as the user has pressed a volume level button, the button will do the necessary action
and the pop-up will disappear.

9. Select File > Save to save your work.

6.8.3 Where is the Pop-up Positioned?

If you open the Pop-up wizard style from another pop-up, this is irrelevant. If you open the pop-up from a regular page, you can
determine roughly where it will be placed like this:

1. Select Page > Page Properties.
On the first tab, General, you will see that Pop-up is checked. (You can also turn a page into a pop-up by checking this
box.)
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2. To control where the pop-up will be positioned when it opens, select a position from the drop down list under Pop-up
page.

Positioning the pop-up.

3. Select OK.

6.8.4 Creating a Wizard

When you link from one pop-up page to a second pop-up page, the check box Use Wizard style become available.

A wizard is a series of dialogs where each one replaces the next. We usually provide the user with Previous and Next buttons
to move between the pages in a Wizard. In Communicator, you have the examples of the Edit Button wizard in Run view, and
the wizard started with Tools > Record New Sound.

If you check Use Wizard Style, there are two differences:

• Pop-up two (destination) will automatically be sized and positioned to fill exactly the same screen space as pop-up one
(origin).

• Pop-up one (origin) will automatically close when pop-up two opens.
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7 Re-using Your Work
This section gives an overview of different ways to re-use buttons and page sets in Communicator.

• On a page, you can duplicate buttons, see 3.4 Adding Buttons by Duplicating, page 17.
• Within a page set you can duplicate a page. Select Page > Duplicate Page. This copies the page and all of its con-

tents to a new page within the page set.
• Using the standard Windows commands you can copy one or more buttons and paste them in elsewhere on the page,

onto another page in the same page set, or into another page set entirely. See 7.1 Copying Buttons, page 69Copying
Buttons.

• When you paste in a button, you can paste a whole button onto an empty part of the page. But you can also paste “just
the actions” (see 7.2 Copying Appearance or Actions Only, page 70) or “just the appearance” (see 5.3 Copying Button
Appearance, page 38) from the original button onto a target button.

• You can open a page set and “save it with a new file name” (see 3.2 Saving Your Work) , and then make changes and
add new pages.

• At this time there is no way to merge two or more existing page sets into a single file. But if you are in a new page set,
and want to add all of the functionality from the old page set, just “link” (see 4.10 Linking Pages Together, page 33) to
the old page set, or copy the page(s) to the new page set.

7.1 Copying Buttons

7.1.1 Copy and Paste Follow Windows Standard

Copy and Paste in Communicator are the standard Windows commands: Copy puts selected button or buttons onto an imagi-
nary clipboard, and paste puts the contents of the clipboard back onto the selected page.

The clipboard only remembers the most recent Copy command. If you select and copy Button A, and then select and copy But-
ton B, Button B will replace A on the clipboard. When you give the paste command, Button B will be pasted in.

7.1.2 When to Copy

Copying buttons is a good approach when you have a group of buttons that you want to re-use. To make many copies of one
button on the same page, see 3.4 Adding Buttons by Duplicating, page 17.

Copying a button always copies:

• Button appearance: button shape, fill color, border width and color, font, font color and font size
• Button content: pictures, text and sounds

• Button actions: links, actions and Smart Button type - if any.

When you paste a button with the regular paste command, all of the above are pasted in. For alternatives, see 7.2 Copying Ap-
pearance or Actions Only, page 70.

7.1.3 How to Copy Buttons

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select the button or buttons you want to copy.
To select more than one button, hold the SHIFT key down while you select additional buttons. Or, press and hold the
mouse button while you drag to draw a selection lasso around a group of buttons.

2. Select Edit > Copy. Or, select the Copy tool on the Standard toolbar

Figure 7.1 The Copy tool.

3. If you want to copy to a different page, choose the destination page from the Page List.
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4. Select Edit > Paste. Or select the Paste tool on the Standard toolbar.

Figure 7.2 The Paste tool.

The last copied material is pasted in at the new location.

7.1.4 Positioning Pasted Objects

When you paste, the buttons arrive with selection marks. If you need to adjust the position of the pasted button or group, point
in the center of a button. Press and hold the mouse button down while you drag to the desired position.

7.2 Copying Appearance or Actions Only
Copying a button always copies:

• Button appearance: Button shape, fill color, border width and color; font, font color and font size.
• Button content: Pictures, text and sounds

• Button actions: Links, actions and Smart Button type - if any.

What happens when you copy and paste depends not so much on what you copy, but on how much you choose to paste in
afterwards.

7.2.1 Copying Appearance with Paste Special

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select the button you want to use as a model.

2. Select Edit > Copy. Or, select the Copy tool on the Standard toolbar.

Figure 7.3 The Copy tool.

3. If you want to copy to a different page, select the target page from the Page List.

4. Select one or more buttons to use as a target. These buttons will be changed to look like your model.
To select more than one button, hold the SHIFT key down while you select additional buttons. Or, press and hold the
mouse button while you drag to draw a selection lasso around a group of buttons.

5. Select Edit > Paste Special > Appearance.
The selected buttons change to match your model.

7.2.2 Copying Actions with Paste Special

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select the single button you want to use as a model.

2. Select Edit > Copy. Or, select the Copy tool on the Standard toolbar.

Figure 7.4 The Copy tool.

3. If you want to copy to a different page, select the target page from the Page List.
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4. Select one or more buttons to use as a target. These buttons will be get the same actions as the model. If the model is a
Smart Button, the same Smart Button type will be applied to the target.
To select more than one button, hold the SHIFT key down while you select additional buttons. Or, press and hold the
mouse button while you drag to draw a selection lasso around a group of buttons.

5. Select Edit > Paste Special > Actions and Smart Button Type.
The selected buttons change to match your model.

7.3 Copying Between Page Sets
Communicator does not have a command to copy whole page sets from one page set to another.

What you can do is copy single pages from the original page set to a page in the new page set.

7.3.1 How to Copy Between Page Sets

In this example, we copy a page from the ready-made page set Cause and Effect to the second page of a new, blank page
set.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Begin in your new page set. Give the command Page > New Page to create a new blank page as the destination.

Figure 7.5 Create a blank destination page

2. Select File > Save, or press CTRL+S to save the destination page set.

3. Select File > Go To> All Page Sets.

4. Select the one of the categories:

• Emerging Communication
• Symbol Communication
• Text Communication
• My Page Sets

or select Browse Files

If you have saved your own page sets in the suggested folder, they will be available under the last tab, My
Page Sets.

5. Select the tab where the Page Set you want to copy from is located

6. Select the Page Set you want to copy the page from.
The page set opens in Run view.

7. Press SHIFT+F5 to go to Edit view.

8. In the page list, select the page you want to copy from.
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Note its page size. The page size is shown in the page list.

Figure 7.6 In the Page List, notice the dimensions.

9. Right-click on the page and select Copy page.

10. In the File menu look down at the recent file list (numbered choices) to find your destination page set. Select the name
to open it.

Figure 7.7 Recently-opened page sets in the File menu.

Your new destination page set opens in Edit view.

11. In the Page List, right-click and select Paste Page. The copied page is added to the page list.
If the copied selection is larger than the destination page, you see this message:

Figure 7.8 The destination page has to be at least as big as the original page.

12. Stretch the destination page larger than the dimensions you remember from step 8, and repeat the command Edit >
Paste.
You can always reduce the page size to match the selection after you paste it in.

13. Select File > Save to save your work.

7.3.2 Copying From a Grid Page

Even if you plan to copy from a grid page, don't apply a grid to your destination page to begin with. Just leave the destination
page blank / a freehand page.

When you copy from a grid page, the buttons will arrive looking like a grid. Resize the destination page to fit the buttons if nec-
essary, and then select Page > Apply Grid.
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7.4 Basing a New Page Set on an Old One
If you just want to add a few pages to one of the included Page Sets, create your new page set based on the old one.

7.4.1 How to Make a new Page Set From an Existing One

1. Open the Quick Menu, by selecting the Menu button on the I-Series(+) device or by right clicking with the mouse.

Figure 7.9 The Quick Menu

2. Select (All Page Sets) button.

3. Select the one of the categories:

• Emerging Communication
• Symbol Communication
• Text Communication
• My Page Sets

or select Browse Files

If you have saved your own page sets in the suggested folder, they will be available under the last tab, My
Page Sets.
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4. You will see a screen similar this:

5. Select the tab containing the page set you want to use as a basis.

6. Select the thumbnail of the page set you want to use.

7. The page set opens in Run view.

8. Right click to access the Menu

9. Select File > Save As.
The standard Windows Save As dialog opens:

Naming your own copy.

10. Check the folder to save in.
If necessary, selectMy Documents > Communicator 5 > user name > My Page Sets, where user name is your
Communicator user name. See 3.2 Saving Your Work, page 15.

11. At the bottom of the dialog, enter a name for your new page set.

12. Select Save.
In the title bar, the file name of the page set changes to the new name.

You are now ready to add pages and buttons of your own.
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8 Picture Libraries
You can add any picture of file format BMP, WMF, GIF or JPG to a page or button. Use the Browse button in any dialog that
helps you to add a picture.

However, it is easier to add a picture from a Picture Library. You don't have to identify the folder first, and you can use a word or
part of a word to search for the picture you want.

Communicator already contains some picture libraries, i.e. SymbolStix and Communicator Symbols.

For how to see what's in these libraries, see 8.3 Viewing Library Content, page 76.

For how to add a library of your own and make it searchable, see 8.1 Adding a Picture Library, page 75.

8.1 Adding a Picture Library
If there is a folder on your PC that contains many pictures you'd like to use, you can tell Communicator to consider that folder as
a Picture Library.

Making the folder a picture library does not change the contents of the folder in any way.

Only pictures with the following file formats will be visible in Communicator: BMP, WMF, GIF, JPG.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select Tools > Picture Libraries.
You see the Picture Library dialog:

2. In the Picture Libraries dialog, select New
Name your new Picture Library.

3. Type a name for your library and select Browse
You see the standard Windows Open dialog.

4. Select the folder you want to become a picture library. Communicator will find all the pictures in this folder and any sub-
folders it contains.

5. In the Open dialog, select OK.

Making Your Own Page Sets Reference manual v.1.0 - en-US 8 Picture Libraries 75



You return to the Picture Libraries dialog, where you see your new library in the list box.

Pictures from the topmost library will be easiest to find.

6. Select OK.
As long as there is a check mark by your Picture Library in the Picture Libraries dialog, your library is searched right along
with the original Communicator libraries. However, your pictures will come last in the results unless you use the arrow
buttons to change the order of the libraries in the list.

8.2 Making Your Own Pictures Easier to Find
When Communicator searches for pictures in a library you added, the file name of each picture supplies the keywords. If the file
names are things like w344235.wmf, you are not going to be able to find your pictures.

If you need to improve the names of your pictures, do this:

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select Tools > Picture Libraries.

2. In the Picture Library dialog, select the name of your own library.

3. Select Explore
The Windows Explorer opens to your library folder.

4. Select View > Thumbnails.
You see your pictures:

You can see the pictures as thumbnails in Windows Explorer.

Beneath each picture is its file name.

5. Point at the file name, Right-click, and choose Rename from the menu.
The file name becomes editable.

6. Replace the old name with several single keywords.
If you see the file type (here it is .jpg) do not change that part of the name.

7. Select outside the file name when you are done editing.

8. Select the Close button at the upper right corner of the Explorer window when you are finished.
The Windows close button.

9. Select OK to close the Picture Libraries dialog.

8.3 Viewing Library Content
When you are using pictures it can be difficult to know what to search for if you don't know what a library contains.

Here's how to view the contents of the SymbolStix library.

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. Select Tools > Picture Libraries.
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You see the Picture Libraries dialog:

2. In the list box, select SymbolStix.

3. Select View Content.
You see the Picture Library Content dialog:

The Library Content Dialog lets you inspect what's in the library and what it's called.

4. Open the drop down list at the top to see all the categories and subcategories.

5. Select one subcategory to see the pictures in that subcategory.
You can also search the library with the search input field at the bottom of the dialog.

6. When you are finished looking, select OK.
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9 Property and Settings
9.1 About Properties and Settings
For many of the Page sets / Smart button types there are both Properties and Settings dialogs - two different places to make
choices.

Why?

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

Settings dialogs let you record the choices that automatically apply to all page sets of a given type, like preferred Keyboard
Layout applies to all of a user's dynamic keyboards.

• Use the Settings menu to find all the settings.

Figure 9.1 Keyboard Layout Settings - a typical settings dialog, found with the Settings menu.

Properties dialogs let you make choices that apply to a single page or page set, for example icons and colors.
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• Open the a Page set in Edit view (If you are not sure which view you are in, press SHIFT+F5). Right-click on a Smart
Button. You'll find the properties command at the bottom of the Right-click menu.

Select a Smart Button in a Phrase Editor Page Set, Right-click, and you get the Phrases Properties command.

• Open a Memory game page set in Edit view (If you are not sure which view you are in, press SHIFT+F5). Right-click on
one of the card buttons, and choose Matching properties to see this Properties dialog.

9.2 Highlighting
For Gaze Interaction users, the native menus on the Gaze controlled device monitor control highlighting of where the user's
gaze is focused. For users whose input method is Scanning, this dialog controls the appearance of the scan cursor. For
Mouse click andMouse dwell users, this dialog can be used to control highlighting of the button during "mouseover", or of
the button just clicked.

9.2.1 How to Configure Highlighting

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.
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1. To reach the dialog, select Settings > Highlighting.

Figure 9.2 Highlighting needs to provide good contrast with buttons and backgrounds.

2. Select an option under Button Highlighting at the bottom of the dialog.
If you intend to use highlighting you must select one of the two top options.

3. Choose Highlighting Style at the top of the dialog.

• Frame, select Thickness and Frame color in the Frame section.
• Invert button you don't need to make other choices.
• Standard colors option at the top, select your colors in the middle section of the dialog that is also called Stand-

ard colors.

4. When you are satisfied with your choices click OK.

9.3 Link Visualization
You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

By enabling Link Visualization, you can show which buttons lead to another page.
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1. To reach the dialog, select Settings > Link Visualization.

Figure 9.3 Links can be visualized through a folded or cut corner, or an icon can be added to each button containing a
link.

2. Select a type and position of the visualization, click OK and run the page (Ctrl+F5).

Figure 9.4 In this Page Set we have chosen Folded corner, which gives this result

9.4 Picture Viewer Settings
Picture viewer settings apply to the Page setMy Pictures. They also apply to any custom page sets you make using the Smart
Button Types and/ or actions specific to My Pictures.

The settings influence which folders are used as picture sources for My Pictures. The folder must be listed here in order for the
pictures to be shown. Pictures in unlisted folders will not be visible in My Pictures.

9.4.1 Making Picture Folders Visible in Viewer

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.
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1. To reach the dialog, select Settings > Picture Viewer.

Figure 9.5 The Picture Viewer Settings dialog is used to control source folders for pictures.

2. To add another picture folder to the list, click the Add button.

3. Choose a folder containing pictures from the standard Windows dialog and click OK.

4. You return to the Picture Viewer Settings dialog. Click OK again.

9.5 Music Player Settings
If your user uses one of the music player page sets, use the Music Payer Settings to define which folders on the PC/device that
contain the music library.

9.5.1 Configuring the Music Library

You must be in Edit view. If you are not sure which view you are in, press SHIFT+F5.

1. To reach the dialog, select Settings > Music Player Settings.

Figure 9.6 Add as many music folders as you want to the Music Library.

2. To add another music folder to the list, click the Add button.

3. Choose a folder containing music from the standard Windows dialog and click OK.

4. You return to the Music Player Settings dialog. Click OK again.

You do not need to Rebuild the library when you add or remove a folder. Communicator automatically looks for new
music or new folders under Selected music folders.

Check Rebuild music library now if you have edited the tags (album, artist and song information, for example) for your music
library with an external editing program. Rebuild will update all the tags, not just the music.
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Support for Your Tobii Dynavox Device

Get Help Online
See the product-specific Support page for your Tobii Dynavox device. It contains up-to-date information about issues and tips & tricks related to the product. Find our Support pages online at:
www.TobiiDynavox.com or www.myTobiiDynavox.com.

Contact Your Sales Representative or Reseller
For questions or problems with your product, contact your Tobii Dynavox sales representative or authorized reseller for assistance. They are most familiar with your personal setup and can best
help you with tips and product training. For contact details, visit www.TobiiDynavox.com/contact
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owners.
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